1、实战目的

掌握通过 DHCP 中继实现跨网络的 DHCP 服务

2.拓扑

dhcp基础配置(实战DHCP中继配置及DHCP命令大全)(1)

R1 仍然担任 DHCP 服务器的角色,负责向 PC1 所在网络和 PC2 所在网络的主机动态分配 IP 地址,所以 R1 上需要定义两个地址池。整个网络运行 RIPv2 协议,确保网络IP 连通性。

3、实验步骤

(1)步骤 1:配置路由器 R1 提供 DHCP 服务

R1(config)# interface gigabitEthernet0/0

R1(config-if)# ip address 192.168.1.1 255.255.255.0

R1(config-if)# no shutdown

R1(config)# router rip

R1(config-router)# version 2

R1(config-router)# no auto-summary

R1(config-router)# network 192.168.1.0

R1(config-router)# network 192.168.12.0

R1(config)# service dhcp

R1(config)# no ip dhcp conflict logging

R1(config)# ip dhcp pool ccie //定义第一个地址池

R1(dhcp-config)# network 192.168.1.0 /24

R1(dhcp-config)# default-router 192.168.1.1

R1(dhcp-config)# domain-name cisco.com

R1(dhcp-config)# netbios-name-server 192.168.1.2

R1(dhcp-config)# dns-server 192.168.1.4

R1(dhcp-config)# option 150 ip 192.168.1.3

R1(dhcp-config)# lease infinite

R1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.5

R1(config)# ip dhcp pool ccnp //定义第二个地址池

R1(dhcp-config)# network 172.16.1.0 255.255.255.0

R1(dhcp-config)# domain-name szpt.net

R1(dhcp-config)# default-router 172.16.1.2

R1(dhcp-config)# netbios-name-server 192.168.1.2

R1(dhcp-config)# dns-server 192.168.1.4

R1(dhcp-config)# option 150 ip 192.168.1.3

R1(dhcp-config)# lease infinite

R1(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.2

(2)步骤 2:配置路由器 R2

R2(config)# interface gigabitEthernet0/0

R2(config-if)# ip address 172.16.1.2 255.255.255.0

R2(config-if)# ip helper-address 192.168.12.1 //配置帮助地址

R2(config-if)# no shutdown

R2(config)# router rip

R2(config-router)# version 2

R2(config-router)# no auto-summary

R2(config-router)# network 192.168.12.0

R2(config-router)# network 172.16.0.0

【技术要点 】

路由器是不能转发“255.255.255.255”的广播,但是很多服务(如 DHCP、TFTP 等)的

客户端请求都是以泛洪广播的方式发起的,我们不可能将每个网段都放置这样的服务器,因

此使用 Cisco IOS 帮助地址特性是很好的选择。通过使用帮助地址,路由器可以被配置为接

受对 UDP 服务的广播请求,然后将之以单点传送的方式发给某个具体的 IP 地址,或者以定

向广播的形式向某个网段转发这些请求,这就是中继。

4.实验调试

(1) show ip dhcp binding

在 PC1 和 PC2 上自动获取 IP 地址后,在 R1 上执行:

R1#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

172.16.1.3 0100.6067.00dd.5b Infinite Automatic

192.168.1.6 0063.6973.636f.2d Infinite Automatic

192.168.1.7 0100.6067.00ef.31 Infinite Automatic

以上输出表明两个地址池都为相应的网络上的主机分配了 IP 地址。

(2) show ip dhcp pool

R1#show ip dhcp pool

Pool ccie

show ip dhcp pool

Pool ccie :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 2

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

192.168.1.8 192.168.1.1 - 192.168.1.254 2

Pool ccnp :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 1

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

172.16.1.4 172.16.1.1 - 172.16.1.254 1

(3) debug ip dhcp server events

在 PC2 上先执行“ipconfig/release”,再执行“ipconfig/renew”,显示如下:

R1# debug ip dhcp server events

R1# clear ip dhcp binding *

*Feb 22 05:50:24.475: DHCPD: Sending notification of DISCOVER:

*Feb 22 05:50:24.475: DHCPD: htype 1 chaddr 0060.6700.dd5b

*Feb 22 05:50:24.475: DHCPD: circuit id 00000000

*Feb 22 05:50:24.475: DHCPD: Seeing if there is an internally specified pool class:

*Feb 22 05:50:24.475: DHCPD: htype 1 chaddr 0060.6700.dd5b

*Feb 22 05:50:24.475: DHCPD: circuit id 00000000

*Feb 22 05:50:26.475: DHCPD: client requests 172.16.1.4.

*Feb 22 05:50:26.475: DHCPD: Adding binding to radix tree (172.16.1.4)

*Feb 22 05:50:26.475: DHCPD: Adding binding to hash tree

*Feb 22 05:50:26.475: DHCPD: assigned IP address 172.16.1.4 to client 0100.6067.00dd.5b.

*Feb 22 05:50:26.519: DHCPD: Sending notification of ASSIGNMENT:

*Feb 22 05:50:26.519: DHCPD: address 172.16.1.4 mask 255.255.255.0

*Feb 22 05:50:26.519: DHCPD: htype 1 chaddr 0060.6700.dd5b

*Feb 22 05:50:26.519: DHCPD: lease time remaining (secs) = 4294967295

以上输出显示了 DHCP 动态分配 IP 地址的基本过程。

(4) show ip interface

R2# show ip interface gigabitEthernet0/0

GigabitEthernet0/0 is up, line protocol is up

Internet address is 172.16.1.2/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is 192.168.12.1

……

Helper address is 192.168.12.1

……

以上输出看到 gigabitEthernet0/0 接口使用了帮助地址 192.168.12.1。

5、DHCP 命令汇总

命令 作用

show ip dhcp pool 查看 DHCP 地址池的信息

show ip dhcp binding 查看 DHCP 的地址绑定情况

show ip dhcp database 查看 DHCP 数据库

show ip interface 查看接口信息

debug ip dhcp server events 动态查看 DHCP 服务器的事件

service dhcp 开启 DHCP 服务

no ip dhcp conflict logging 关闭 DHCP 冲突日志

ip dhcp pool 配置 DHCP 分配的地址池

network DHCP 服务器要分配的网络和掩码

default-router 默认网关

domain-name 域名

netbios-name-server WINS 服务器

dns-server 域名服务器

option 150 ip FTP 服务器

lease 配置租期

ip dhcp excluded-address 排除地址段

ip helper-address 配置 DHCP 中继的地址

以下是华为数通路由交换方向完整技术分享,欢迎对华为网络技术感兴趣的小伙伴们订阅。

华为新版HCIA数通路由交换

华为新版HCIP数通路由交换

华为新版HCIE数通路由交换

,